UMGUM.COM (лучше) 

Два или более Cisco HWIC-4ESW ( Два и более модуля Cisco HWIC-4ESW на одном шасси. )

9 апреля 2010  (обновлено 31 января 2015)

OS: Cisco IOS 12.4/15.1.

Применимо к: Cisco 1800/2800/3800.

Протестировано на: Cisco 1841, 2811, 3845.

Задача: задействовать все имеющиеся модули HWIC-4ESW в маршрутизаторе Cisco.

В нашем маршрутизаторе есть возможность использовать заменяемые модули со стандартным интерфейсом подключения к шасси. Возможность удобная, безусловно, и, все бы хорошо, но без нюансов с не совсем очевидным происхождением не обходится. В частности, в нашем случае, использовать два и более модуля HWIC-4ESW или HWIC-8ESW в одном шасси без "костыля" не получится. Суть проблемы в том, что второй (третий и так далее) модуль распознаётся системой, его можно конфигурировать, но вот работать он попросту не будет. Для задействования необходимо связать первый и последующий модули процедурой "стекирования", иначе говоря, объявить коммутаторы, которыми являются наши модули, партнёрами по виртуальному "стеку" и представить их как единый виртуальный коммутатор. Не скажу, чтобы после всех проделанных процедур, наши модули станут конфигурироваться как единый коммутатор, ничего подобного, и в дальнейшем они выглядят как два и более разных модуля в системе.


В процедуре "стекирования" коммутаторов-модулей для меня почти все не очевидно и полученный результат не соответствует моим ожиданиям, но, в конце концов, я не специалист в сетевом оборудовании совершенно, занимаюсь его конфигурированием вынуждено и "оно работает".

Удостоверяемся в том, что модули наличествуют в шасси и опознаны системой:

router# sh run

interface FastEthernet0/0/0
interface FastEthernet0/0/1
interface FastEthernet0/0/2
interface FastEthernet0/0/3

interface FastEthernet0/1/0
interface FastEthernet0/1/1
interface FastEthernet0/1/2
interface FastEthernet0/1/3

Объявляем последний порт первого модуля "стек-партнёром" последнего порта второго модуля:

router# conf t
router(config)# interface FastEthernet0/0/3
router(config-if)# no ip address
router(config-if)# switchport stacking-partner interface FastEthernet0/1/3
router(config-if)# no shutdown
router(config-if)# speed auto
router(config-if)# duplex auto
router(config-if)# exit

Получаем уведомление о том, что "партнёрство" заработает после того, как оба порта будут инициированы:

*Apr  7 10:38:58.255: %ESWMRVL_FLTMG-5-NOTICE: Notice: Either Fa0/0/3 or Fa0/1/3
is not ready for stacking. Stacking command is accepted and will take effect wh
en both links come up.

В объявлении параметров второго порта "партнёра" нет необходимости, но можно это проделать хотя бы для того, чтобы привести параметры порта к требуемому виду:

router(config)# interface FastEthernet0/1/3
router(config-if)# no ip address
router(config-if)# switchport stacking-partner interface FastEthernet0/0/3
router(config-if)# no shutdown
router(config-if)# speed auto
router(config-if)# duplex auto
router(config-if)# exit

В различных инструкциях, прочитанных мной на разрабатываемую тему, рекомендуется соединять порты так называемым "кросс-овер" кабелем. На практике, у меня порты обеих модулей работают даже при соединении посредством "обычного" Ethernet 5e "патчкорда".

Представляется весьма странным то, что для связи двух коммутаторов в пределах одного шасси нужно связывать их внешними кабелями, а не производить средствами самого маршрутизатора, но чего-то я не знаю, и это именно то, что нужно для того, чтобы не рассуждать много на эту тему.

Проверяем состояние наших интерфейсов:

router# sh run

interface FastEthernet0/0/0
interface FastEthernet0/0/1
interface FastEthernet0/0/2
interface FastEthernet0/0/3
switchport stacking-partner interface FastEthernet0/1/3

interface FastEthernet0/1/0
interface FastEthernet0/1/1
interface FastEthernet0/1/2
interface FastEthernet0/1/3
switchport stacking-partner interface FastEthernet0/0/3

router# sh interfaces FastEthernet0/1/3

FastEthernet0/1/3 is up, line protocol is down
  Internal Stacking Link Active : Fa0/1/3 is stacked with Fa0/0/3
  Hardware is Fast Ethernet, address is mac.address (bia mac.address)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
    2 packets input, 166 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    1 packets output, 81 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out

Пробуем запустить в работу интерфейсы из первого и второго модуля:

router(config)# vlan database
router(config-vlan)# vlan 102 media ethernet name Vlan102
router(config-vlan)# vlan 112 media ethernet name Vlan112
router(config-vlan)# exit

router(config)# conf t
router(config)# interface Vlan102
router(config-if)# ip address 192.168.102.2 255.255.255.0
router(config-if)# no shutdown

router(config)# interface Vlan112
router(config-if)# ip address 192.168.112.2 255.255.255.0
router(config-if)# no shutdown

router(config)# interface FastEthernet0/0/2
router(config-if)# switchport mode access
router(config-if)# switchport access vlan 102
router(config-if)# no shutdown

router(config)# interface FastEthernet0/1/2
router(config-if)# switchport mode access
router(config-if)# switchport access vlan 112
router(config-if)# no shutdown

Оно будет работать, если все, что выше написано, сделано верно.

В итоге, мы имеем два модуля по четыре порта, но можем распоряжаться только шестью портами; не красиво, конечно, но в каком-то случае это может быть единственным выходом из проблемной ситуации.


Заметки и комментарии к публикации:


Оставьте свой комментарий ( выразите мнение относительно публикации, поделитесь дополнительными сведениями или укажите на ошибку )